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Overview
Aperio Image Quality (IQ) technology gives pathologists and
other scientists who view digital slides the ability to
customize the view of those slides to boost productivity and
visual clarity by digitally adjusting the stain colors, viewing
the individual stain images, and/or re-mixing the stains on
the fly while they navigate the image.
In many cases, the judgment of what is a “good” slide depends on:


What you are trying to accomplish in viewing that slide



Personal preferences concerning color, lightness versus darkness, cell
structure emphasis, and so on.

IQ allows you to choose for yourself what view of the digital slide gives you the
best results and makes it easier for you to identify the features of the slide you
are most interested in.

IQ Features
IQ uses color processing—analyzing each pixel of the digital slide image—to
identify stains and modify their appearance on the digital slide. Some of its
features include the ability to:


View a selected stain as you navigate the digital slide. IQ uses color
deconvolution to separate the stains and present them as you pan or
scroll about the image.



Boost or dilute the displayed concentration (especially useful for
overstained or understained slides, or to suit your personal preference).



Enhance cellular detail such as nuclei.



Digitally adjust individual stain colors for visual clarity and personal
preferences (for example, darker/lighter, more or less vibrant,
bluer/redder, and so on).
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Here is a simple example of what IQ can do for you. IQ transformed the view of
a poorly stained Hematoxylin & DAB slide (on the left) to one in which tissue
structures are clearly delineated (on the right):

How IQ Works
IQ is an option within the ImageScope digital slide viewer. IQ enhances the view
of a digital slide by allowing you to define visual characteristics of the stains you
use. IQ does not change the actual digital slide, and the visual enhancements it
makes are applied only for the current ImageScope viewing session. However,
you can save the stain adjustments you make so you can apply them to the view
of other digital slides. At any time you can turn IQ on or off for a specific digital
slide even when viewing multiple slides simultaneously.

Prerequisites
ImageScope must be installed on each workstation on which users will be
viewing digital slides.
Your site must be licensed for Spectrum Plus and you must open images in
ImageScope in Spectrum Plus to use IQ (that is, you cannot use IQ for images
you open locally on your workstation or local area network).

Stains
IQ’s perspective on all digital slides is that they are composed of individual
stains. Stains to IQ are a color vector—a color that ranges in intensity from dark to
light.
Many stain definitions are delivered with IQ. You can replace the delivered IQ
stain definitions with measurements from your control slides or from single‐stain
areas on test slides. Similarly, you can extend the list of IQ stains.

2
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Stain Sets
You are already familiar with the stains used in your tests—for example an H&E
slide uses Hematoxylin and Eosin stains and an ER slide uses Hematoxylin and
DAB stains. With IQ, you define your stain set—the two or three stains that make
up your test and the IQ enhancements to be performed on each of those stains.
For example, you may devise one IQ stain set for a lightly stained H&E digital
slide, one for a darkly stained H&E digital slide, and another for a HER2/neu
digital slide.
To use IQ when viewing a digital slide, select a stain set from the IQ drop‐down
list on the ImageScope toolbar. Then, as you navigate the digital slide, IQ applies
the enhancements defined in that stain set to the image.
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Quick Tour
This chapter gives a tour of the IQ user interface, showing a
quick example of using IQ on a digital slide created from an
H&E-stained slide. For details on each function, see the
following chapters.

Opening an H&E Digital Slide in ImageScope
You can use IQ with a slide stained with any stain, but for this quick introduction
we will use an H&E‐stained slide.
To open an H&E digital slide:
1.

Log into Spectrum with your user name and password.

2.

On the main Spectrum page, click List All Digital Slides in the Digital
Slides section:

The appearance of
the Spectrum main
page may differ
slightly from the
example depending
on how Spectrum is
configured at your
site.
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3.

On the Digital Slides list page, click the thumbnail image of an H&E‐
stained digital slide to open it in ImageScope:

The digital slide appears in the main ImageScope window:

This is the default view of this digital slide before IQ is applied to it.
4.

6

Click the down‐arrow next to the

icon and select Default:
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This applies the Default stain set to the image:

Notice the small pink box at the bottom left, which tells you that the
Default stain set has been applied to the image.
5.

To turn IQ off, click the
icon again and the pink box at the bottom
left disappears as IQ is turned off.

Because most glass slides are stained with Hematoxylin and Eosin (H&E), the
Default stain set contains basic settings for H&E‐stained digital slides.
Depending on your particular digital slide, turning on IQ and using the Default
stain set may make a meaningful difference in the view or the results may be
more subtle. (Some of the more subtle changes may be difficult to see on the
printed page in this guide, but will be more obvious when you see the digital
slide in ImageScope.) In later chapters, we will show you how to develop your
own stain sets that are optimized for your preferences and staining process.

Viewing Individual Stains
To open the IQ application:
1.

On the ImageScope menu bar, go to the Image menu and select Quality.
(If the Quality command is not enabled in the Image menu, click the
icon on the ImageScope toolbar to turn on IQ.) Or, type Control Q after
turning on IQ.
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The Image Quality viewing toolbar appears:

This viewing toolbar is available on every tab of the IQ application
window.
2.

To see the digital slide with only Stain A (Hematoxylin in this case)
applied, click A:

With the cursor on
the viewing toolbar
controls, you can
progress through
the views by
pressing the
keyboard space bar.

and only the Hematoxylin stain is displayed:

Subtracting the
visual representation
of a stain from an
image of a digital
slide that was
stained with more
than one stain is
called color

deconvolution.

Notice that the
image thumbnail
always shows the
original image with
all stains applied.

3.
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To see the digital slide with only Stain B (Eosin in this case) applied,
click B:
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and only the Eosin stain is displayed:

4.

To see the digital slide with both stains applied, click AB:

and both stains are displayed:
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Measuring Stains
Several IQ functions are for defining and saving stain sets based on manually
selecting stains, and changing concentration, intensity, and color settings. IQ also
allows you to measure the color of the stains you use in your lab to create new
stain definitions you can use in those stain sets.
For best results, we recommend scanning a control slide stained with a single
stain. Then measure the stain on the digital slide to get a good representation of
the stain used in your lab.
To open the IQ application:
1.

On the ImageScope menu bar, go to the Image menu and select Quality.
(If the Quality command is not enabled in the Image menu, click the
icon on the ImageScope toolbar to turn on IQ.) Or, type Control Q after
turning on IQ.
The IQ viewing toolbar appears.

2.

10

Click Details to see the entire IQ window:
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3.

Click the Manage Stains tab. We will go into more details on using this
tab in Chapter 5, “Measuring Stains” on page 29. However, for now we
will point out a few features.

4.

Click Measure.

This opens the Stains Measurement window. As you move it to different areas of
the digital slide, you see the area of the digital slide that is under the viewing
pane.



IQ chooses a stain that is the closest match to the color being viewed and
displays it in the text window.



The color bar shown is a representation of the dominant color of the area
you are measuring.



You can save the stain you are measuring using your own stain name in
the Save box or you can use the closest match name, overwriting that
saved stain with this measurement from your lab.
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Additional viewing options are available in the View menu on this
window (explained in Chapter 5, “Measuring Stains” on page 29).

Defining the Stain Set
The Stains Applied, Re‐Mix and Re‐Color tabs of the IQ application allow you to
identify the stains you are using and modify the display settings for the stains
and save them as a custom stain set.
As soon as you begin to change the stain set settings, notice that the name of the
stain set at the top of the IQ window becomes Custom. You will be able to save
and name your newly created stain set later—see Chapter 6, “Creating or
Modifying a Stain Set” on page 33.

Identifying Stains
To open the IQ application:
1.

On the ImageScope menu bar, go to the Image menu and select Quality.
(If the Quality command is not enabled in the Image menu, click the
icon on the ImageScope toolbar to turn on IQ.)
The Image Quality viewing toolbar appears.

12
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The color bar next
to the stain name
shows the basic
color range for that
stain, darkest to
lightest absorption.
Each block is the
same color (hue),
but a different
intensity.

2.

Click Details to see the entire IQ window:

On this window, you can select the stains that were used to stain the
current digital slide. Because we applied the Default stain set, which is
based on Hematoxylin and Eosin, IQ already knows that the digital slide
we opened was stained with H&E and so displays Hematoxylin HE in
the Stain A box and Eosin in the Stain B box. Since no third stain is
defined in this stain set, Null appears in the Stain C box.
On another IQ tab you will be able to measure the visual representation
of the stains used in your lab, so that the stain selections match your own
control slides.
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Re-Mixing Stains
The results of staining glass slides in your lab differ depending on the
concentration or dilution of your stains (for example, slides made at the end of a
staining run might be lighter in color than those made at the beginning). The Re‐
Mix tab gives you a way to change the visual representation of your stain
concentration:

To see the clearest representation of your changes, you may want to use the
viewing toolbar to view a single stain at a time. For example, when adjusting
Stain A (in this case, Hematoxylin), set the view to Stain A.

14
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Diluted

For each stain, use the Dilute/Concentrate controls to visually dilute or
concentrate the stain (sliding to the left dilutes the stain; sliding to the
right concentrates it). The results are visible in the main ImageScope
window. For example, the images below show diluted versus
concentrated Hematoxylin stain:

Concentrated



For each stain, use the Cell Emphasis controls to boost or reduce the
visual emphasis of cell structures. (Of course, not all stains are used to
identify cell structures, so you must decide if this control is appropriate
for your application.)



Use the Intensity control to boost the intensity of the entire image. For
example, in the image below we set intensity to 1.5, which resulted in a
much darker image:
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Re-Coloring Stains
The Re‐Color tab gives you the opportunity to change the color for your stains.
For example, if your personal preference is that Hematoxylin appear more
“blue,” you can use this tab to make that change.

As on the Stains Applied tab, the color bar next to the stain name shows the basic
color range for that stain, darkest to lightest absorption for the definition of that
stain. The three numeric boxes starting from the left are the numeric
representations of the stain vectors in RGB format (red, green, and blue) from
zero to 255. For example, to boost the “redness” of Eosin, we would increase the
number in the first box under that stain (and perhaps reduce the amount of blue
in the third box). To see the effects of your re‐color changes, click the Refresh
View button.

16
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Saving the Stain Set
You can save a
maximum of 100
stain sets.

Once you have set the stain settings to suit your preferences, you can save the
settings as a new stain set on the Manage Sets tab. You can both save and delete
stain sets.
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Getting Started
This chapter discusses how to get started with IQ and its
different modes of use.
IQ offers two modes of use:

1. Enhance the view of a digital slide by applying an existing stain set (a
stain profile) to the digital slide. You will use this mode after you have
developed and fine‐tuned your own stain sets that are appropriate for
your staining process and personal preferences.

2. Create and fine‐tune stain sets that you can apply to the view of digital
slides. When creating your own stain sets, you can:
a) Measure the color of the actual stain used and save it as the standard
for that stain. See Chapter 5, “Measuring Stains” on page 29.
b) Tell IQ what stains were used on a specific digital slide (either using
the predefined stain definitions shipped with IQ or your own stain
definitions saved when you measured your stains) and then fine‐
tune the settings for those stains until you are pleased with the view
of those stains. See Chapter 6, “Creating or Modifying a Stain Set” on
page 33.
IQ is an option of the ImageScope digital slide viewer. The enhancements it
makes to the view of the digital slide are in effect only for that session of
ImageScope and are not stored with the digital slide.
You can turn IQ on and off for a specific digital slide even when viewing
multiple digital slides simultaneously.

Enabling IQ in ImageScope
IQ can be used in ImageScope only on a Spectrum site licensed for Spectrum Plus
and when opening an image from Spectrum (that is, not when viewing a local
digital slide on your workstation or local network).
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Opening a Digital Slide in Spectrum
To open a digital slide from Spectrum:
1.

Log into Spectrum with your user name and password.

2.

On the main Spectrum page, click List All Digital Slides in the Digital
Slides section:

(The exact list of items you see on the main Spectrum page differs
depending on the Spectrum configuration.)
3.

20

On the Digital Slides list page, click the thumbnail image of a digital
slide to open it in ImageScope:

IQ Image Quality User’s Guide

Chapter 3 – Getting Started

The digital slide appears in the main ImageScope window:

This is the default view of this digital slide before IQ is applied to it.

Applying a Stain Set
Two stain sets are provided with IQ:


Default – Because most slides are stained with H&E, IQ comes with a
Default stain set that has been optimized for H&E‐stained slides. You
can fine‐tune this stain set by overwriting it with one modified for your
preferences.



None – This stain set contains no settings. Apply it when you want to
develop your own stain set not based on an existing one.

Later in this guide you will develop your own stain sets that can be applied to
digital slide views.
To apply a stain set:
1.

IQ Image Quality User’s Guide

Open a digital slide in ImageScope.
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2.

Click the down‐arrow next to the

icon and select a stain set:

As you create your own stain sets, each new stain set will be added to
the list of stain sets that can be applied to digital slide views. The
currently applied stain set is shown with an asterisk in the list.
Selecting a stain set applies the selected stain set to the image:

Notice the small pink box at the bottom left, which tells you which stain
set has been applied to the image.

22
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3.
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To turn IQ off, click the
icon again and the pink box at the bottom
left disappears as IQ is turned off. For example, below is the view of the
same digital slide as above with IQ turned off. Note that the small pink
box at the lower left is gone and image looks slightly different than in
the previous example.
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Viewing Multiple Digital Slides with IQ
With more than one digital slide in the ImageScope viewing window, select each
digital slide image separately by clicking on it and then applying the IQ stain set
you want to use with that digital slide. In the example below, one digital slide
has the Default stain set applied and the other has a Hematoxylin + DAB stain set
applied:

24
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Viewing Individual Stains
An important feature of IQ is that it allows you to easily see
separate views of the stains used to stain your slide. This
chapter discusses using the viewing toolbar to see separate
stain channels.
By separating the view of a digital slide into separate stain color channels, you
can isolate features of interest.

Using the Viewing Toolbar
1. Open a digital slide in ImageScope as discussed in Chapter 3, “Getting
Started” on page 19.

2. Apply a stain set to the digital slide (see “Applying a Stain Set” on page
21).

3. Go to the ImageScope Image menu and select Quality to open the IQ
application. (If the Quality command is not enabled in the Image menu,
click the
icon on the ImageScope toolbar to turn on IQ.) Or, type
Control Q after turning on IQ.
The IQ viewing toolbar appears.

By using each viewing toolbar control, you can see just a single stain channel or
all combinations of the stains. The button for the stain or stain combination
currently being viewed is shaded in blue.

IQ Image Quality User’s Guide
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Toolbar Control

Description
Go to the next stain channel.
Go to the previous stain channel.
Select stain channel. Every combination of the stains defined
appears on a button.

Details button

Return to the detailed IQ application window.

View Only button

Return to just the viewing toolbar display.
When your cursor is on the viewing toolbar, you can navigate

Space bar

through the stain channel buttons, moving one button ahead
with each press of the keyboard space bar.

If three stains have been defined, the viewing toolbar shows buttons for all three
stain channels and all combinations of those channels:

26
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Examples of Separate Stain Channels
The samples below show an H&E‐stained slide image being viewed as separate
and combined stain channels.

Hematoxylin and Eosin Channels

Hematoxylin Channel

IQ Image Quality User’s Guide
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Eosin Channel
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Measuring Stains
Measuring stains allows you to define the visual characteristics of
the stains you use.
The next chapters discuss manually changing the settings for stain sets to make
them more appropriate for your preferences and staining process.
In this chapter you will learn how to measure the colors used by your specific
stains and save those settings as stain definitions that you can use in your stain
sets.

Measuring Stains
We recommend using this procedure on a digital slide that was scanned from a
control glass slide (that is, a good quality slide that was stained with only one
stain). If you don’t have a control slide, use a digital slide that was scanned from
a slide in which you can easily identify areas stained with a single stain.

1. Open a digital slide in ImageScope and enable IQ. (See Chapter 3,
“Getting Started” on page 19.)

2. Go to the ImageScope Image menu and select Quality to open the IQ
application. (If the Quality command is not enabled in the Image menu,
click the
icon on the ImageScope toolbar to turn on IQ.) Or, type
Control Q after turning on IQ.
The IQ viewing toolbar appears.

3. Click Details to open the entire IQ window.
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4. Go to the Manage Stains tab:

5. Click Measure. A Stain Measurement window appears:

When you are using the Stain Measurement window, IQ does not apply
any settings made in the other IQ tabs. That is, the measurement is taken
on the raw/base image before any IQ adjustments are applied.

6. Move the Stain Measurement window so that the viewing pane is placed
over the area of the digital slide that you want to measure. The viewing
pane measures the dominant color in the area under the viewing pane.

30
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Note that you can grab the lower left corner of the viewing pane (the
cursor changes to a double arrow) and drag the window so that the
viewing pane is the appropriate size for the area you want to measure.

Based on the color in the viewing pane, IQ suggests the closest stain
match it can find and displays it in the first text box. In the example
above, this is Fast Red.

7. Save the sample as a new stain name by typing its name in the second
text box and clicking Save. For example, if you save the stain as Fast Red
2, in the future you can select Fast Red 2 on the Stains Applied tab when
identifying the stains used on digital slides. IQ will then adjust the
display of the Fast Red stain used on digital slides to the visual
representation of the Fast Red stain used in your lab.

Stain Measurement Display Options
By using the View menu on the Stain Measurement window, you can choose
from a variety of viewing options:



Color Bar – The stain color bar shows the basic color range for that stain,
darkest to lightest absorption.



Closest Match – The stain in the IQ list of stains that most closely
matches the current sample based on its color. This is IQ’s best guess;
you may want to overwrite it with the sample of your own stain.
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Color Vector RGB – The RGB values for the current sample:

For a discussion of color vectors, see “The Color Vector” on page 40.

32



Color Vector OD – Color optical density is another method of
quantifying color values.



Center RGB – Selecting this option causes a cross hair to appear in the
viewing pane. The RGB values for the pixel that lies at the exact center of
the cross hair are displayed.



Save Stain – Selecting this option enables the save stain box and button.

TIP: Color vector OD
values can be used
as input to the
Aperio Color
Deconvolution or
Colocalization
algorithms.
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Creating or Modifying a Stain
Set
In this chapter you will use several IQ features to create or
modify a stain set.

Identifying the Stains Used on Your Slide
In this section you will select the stains used to stain the glass slide from which
the current digital slide was created.
The list of stains provided by IQ give good approximations of the color
definitions for those stains, but may not precisely match the values of the stains
you use. This is why the Re‐Mix and Re‐Color tabs are provided to allow you to
fine‐tune the definitions to more closely match your stains and your personal
preferences.
You may want to use a digital slide made from a control slide to precisely
measure the color of a stain used by your lab to create a stain definition based on
that stain. See Chapter 5, “Measuring Stains” on page 29 for details.

Opening the IQ Application
Open a digital slide in ImageScope and apply the None stain set to the slide
view. (See “Applying a Stain Set” on page 21 for instructions.) If instead of
creating a new stain set you want to modify an existing one, apply the stain set
you want to modify.
To open the IQ application:

1. Go to the ImageScope Image menu and select Quality to open the IQ
application. (If the Quality command is not enabled in the Image menu,
click the
icon on the ImageScope toolbar to turn on IQ.) Or, type
Control Q after turning on IQ.
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The IQ viewing toolbar appears.

2. Click Details to open the entire IQ window. The IQ application window
appears:

Notice that the stain set applied is shown in the window title bar.
If you have applied the None stain set, no stains will yet be defined and
the color bars after the stain definition boxes will be monochrome and
the viewing toolbar will be disabled. (For information on the viewing
toolbar, see Chapter 4, “Viewing Individual Stains” on page 25.)

34
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Selecting the Stains

1. Click the down‐arrow next to stain definition box A and choose a stain
used to stain this digital slide.

2. Repeat for each of the stains used.
You can specify up to three stains. If you used less than three stains,
leave one or more stain definition boxes set to Null.
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In the example below we have selected Hematoxylin and Eosin. Note that the
window title bar now shows Custom, View = Hematoxylin HE + Eosin. The
word “Custom” means that we have begun to create a new stain set.


The stain color bar shows the color vector, the
basic color range for that stain, darkest to
lightest absorption for the current definition
of that stain. For a discussion of color vectors,
see “The Color Vector” on page 39.



The Custom stain set will not be saved when
you exit the IQ application. If you want to
save the Custom settings you have made, go
to the Manage Sets tab and save the settings
as a new stain set or override an existing one.



Once stains have been selected, the viewing
toolbar at the bottom of the window is
enabled for viewing the digital slide’s
different stain color channels separately or
together. See Chapter 4, “Viewing Individual
Stains” on page 23.

Re-Mixing Stains
Once you have defined the stains used for your digital slide, you can use the IQ
Re‐Mix tab to change the “mix” for each stain visually diluting or concentrating
the stains used for that slide. To a certain extent, your re‐mix settings will reflect
personal preference, but these settings can also be useful if you are using a batch
of slides that were understained or overstained as you can correct that condition
when viewing the digital slide made from those slides.

Diluting/Concentrating Stains
Normal variation in the staining process and in the stain itself can result in slides
that are lighter or darker than you prefer. You can use IQ to concentrate or dilute
the visual representation of the stains on your digital slides.
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1. Go to the Re‐Mix tab:

2. Click a channel button on the viewing toolbar to select one stain channel.
For example:

3. Now slide the Dilute/Concentrate control to the left to dilute the stain or
to the right to concentrate it until you are pleased with the result.
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4. Click another channel button on the viewing toolbar to select another
stain channel and repeat step #3 until all stains are adjusted.

Changing Cell Emphasis
Some stains, like Hematoxylin, are specifically designed to make it easier to
identify cell structures. If you wish to emphasize cell structure for that stain
channel, select the channel on the viewing toolbar and use the Cell Emphasis
slider to increase or decrease cell emphasis.

Changing Overall Intensity
To change the overall intensity (lightness/darkness) for the entire image to your
personal preference, select the button on the viewing toolbar that selects all
channels and move the Intensity slider to the left to reduce intensity or to the
right to increase it.

Resetting Re-Mix Values
To return all settings on the Re‐Mix tab to the last‐saved values, click the Reset
Re‐Mix button.

Re-Coloring Stains
In “Identifying the Stains Used on Your Slide” on page 33, you selected the stains
used for your digital slide. In this chapter you can fine‐tune the colors displayed
for those stains.
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Changing Stain Colors

1. Go to the Re‐Color tab:

The RGB values are displayed for each stain, which define the Red,
Green, and Blue channel values from zero to 255.

2. Select a single stain channel in the viewing toolbar and adjust the RGB
values for that stain to your preference. Either type the new value in one
of the RGB boxes or click the arrows to increase or decrease the value.
For example, if you want Hematoxylin to display as more “blue,”
increase the number in the third RGB box for that stain.

3. Click Refresh View to see your changes in the ImageScope window.
(Unlike other IQ tabs, this tab requires that you manually apply your
changes to the image view by clicking Refresh View.) Note that it is
usually necessary to half or double the R, G, or B values to see a
difference.
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The Color Vector
The color bars on the Stains Applied and Re‐Color tab show color vectors. If you
consider a color wheel in which traveling around the wheel changes the color (or
hue), but traveling outward in a straight line from the center of the wheel keeps
the hue the same but changes the intensity, the color vector represents that
straight line from the center of the wheel (see the illustration). The RGB values
define the hue of the stain when it is at its most concentrated.

Resetting Colors
To reset the colors to the last‐saved values, click Reset Re‐Color.

Managing Stain Sets
You can create and save your own stain sets as well as delete existing stain sets.

Saving Settings as a New Stain Set
1.

Go to the Manage Sets tab:

Sample Color Vector

2.
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Type a new stain set name in the Save Set text box and click Save. Note
that you can overwrite an existing stain set, including Default, by
specifying its name.

Changing the
Default stain set and
overwriting it will
permanently change
that stain set. If this
is not what you want
to do, we suggest
you use a new stain
set name rather than
Default when saving
the modified stain
set.
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3.

A message tells you that the stain set was saved:

Deleting Stain Sets
To delete a stain set:

1. On the Manage Sets tab, select the stain set you want to delete from the
Delete Set drop‐down list:

2. Click Delete. A confirmation window appears:

3. Click Yes.
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